SIP URI - Private IP Address

Go down

SIP URI - Private IP Address

Post by dcs on Fri Nov 16, 2018 12:28 pm

Hi,

I have been testing FreeSBC on AWS and every time I send a call to my SIP provider I am getting 401 unauthorized. I checked with them and they said the reason is because you are including the private IP in the SIP URI.

Code:

INVITE sip:514xxxx@206.80.xxx.xxx SIP/2.0 Content-Type:application/sdp
To: <sip:514xxxx@206.80.xxx.xxx>
From: <sip:514xxxxxxx@192.168.31.19>;tag=C7C7303033303330B5980000
Privacy:none
P-Asserted-Identity: <sip:514xxxxxxx@192.168.31.19>
Max-Forwards:65
Allow:INVITE,ACK,OPTIONS,BYE,CANCEL,REGISTER,INFO,UPDATE,PRACK,REFER,SUBSCRIBE,NOTIFY
Supported:100rel,timer
Expires:120

They said From: <sip:514xxxxxxx@192.168.31.19>;tag=C7C7303033303330B5980000 should contain the public IP of the SBC.

On the NAP configuration, I tried to set the "Remote Method for SIP" to "Force Use of Public IP and Port" and also "Automatic NAT Traversal" but they still see the private IP of SBC.

How can I correct this?

Thanks.

dcs

Number of Messages : 3
Registration Date : 2018-10-17

Back to top Go down

Re: SIP URI - Private IP Address

Post by Admin on Tue Nov 20, 2018 8:11 am

Hi

Would you tell us which FreeSBC release are you using?

Admin
Admin

Number of Messages : 184
Registration Date : 2017-11-27

http://forums.freesbc.com

Back to top Go down

Re: SIP URI - Private IP Address

Post by dcs on Tue Nov 20, 2018 8:40 am

Hi,

It is 3.0.107 running on AWS.

Thanks.

dcs

Number of Messages : 3
Registration Date : 2018-10-17

Back to top Go down

Re: SIP URI - Private IP Address

Post by NicoleTan on Tue Nov 20, 2018 11:06 am

Hi  David,

It is normal that the From header has the private IP, we already put the src IP which initiates the Invite.
However, you can manipulate it Via Route -> Remapped_Calling: /^([0-9]*)$/\1@ 35.183.232.213/

NicoleTan

Number of Messages : 2
Registration Date : 2017-11-27

Back to top Go down

Re: SIP URI - Private IP Address

Post by dcs on Wed Nov 21, 2018 9:02 pm

Hi Nicole,

The issue was with realm. After setting the proper value under the NAP settings, everything worked.

Thanks.

dcs

Number of Messages : 3
Registration Date : 2018-10-17

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum